引用博文

前言:在安装Nodejs过程中出现了如下报错

node: relocation error: /lib64/libnode.so.93: symbol FIPS_selftest, version OPENSSL_1_1_0g not defined in file libcrypto.so.1.1 with link time reference

在升级了Openssl,Openssh无果之后,在百度/Google检索,很少有见到这类问题的解决办法,只能尝试上文中提到的降级方式,刚好我的服务器也是glibc2.17版本。

ldd --version

安装

下载历史NodeJs版本

安装配置NodeJs

yum install gcc gcc-c++

tar -xvf node-v12.19.1-linux-x64.tar.gz

mv node-v12.19.1-linux-x64 node

#配置环境变量
vim /etc/profile
export NODE_HOME=/usr/local/node
export PATH=NODE_HOME/bin:PATH
source /etc/profile

验证

node -v
npm -v

ps:记录一次爬坑,升级openssh/l可以看以往博文
CentOS 7 离线更新升级 openSSH 8.8p1